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1 About this manual
This document describes tasks and functionality of the SMU Auto Logs software.

SMU Auto Logs is used to automatically download logs from the Shadow Master Unit V4 (SMU) of
our system for shadow impact monitoring and species conservation and export the most important
data to a CSV file. 

For more information on the SMU, please refer, e.g., to the latest version of the Shadow Manager 4
manual, which can be downloaded from our website.

Since SMU Auto Logs offers a large number of setting options and although we have designed the
user interface to be user-friendly and intuitive, you will need to refer to this help, especially as a be-
ginner, but now and then even if you are an experienced user.

Please read the information relevant to you carefully, so that you can use SMU Auto Logs in the
best possible way and as intended by the manufacturer.

Conventions1.1
The following conventions apply:

Marking Meaning

Bold

In the body text, names of menus, windows, buttons, etc. are written in
bold.

Example: Open the Connections window. 

Bold writing is also used to highlight important parts within a text block.

Italic, blue Path names are shown in italics and blue.

Example: View > Connections > Schedule.

Blue,
underlined

Cross-references are highlighted in blue font color and underlined. Click on
a cross-reference in order to jump to its target. Links that have been
clicked on before change their font color to purple.

Purple, 
underlined

Cross-references you have already used once are highlighted in purple
font color and underlined.

Highlighted in green
In the explanation for the parameters, you will find information on the input
format, input range, etc. highlighted green, where applicable and appro-
priate.
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Abbreviations1.2
The following abbreviations are used

Abbrev. Designation Information

POI Place of immission Building with walls and areas to be protected from
shadow impact.

SM4 Shadow Manager4 The operating software for our system for shadow im-
pact monitoring and species conservation. 

SMU Shadow Master Unit The central unit of the system for shadow impact
monitoring and species conservation.

WTG Wind turbine generator -

Digital navigation aids1.3
When you read this manual in digital form on the screen, you can click on a cross-reference in many
places to go directly to a section with further information. Cross-references are highlighted by
blue/purple color and underlining. In addition, you can display the table of contents in PDF Reader
on the left-hand side of the window and navigate within it.
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2 Introduction
SMU Auto Logs is used to automatically download logs from the Shadow Master Unit V4 (SMU) of
our system for shadow impact monitoring and species conservation and export the most important
data to a CSV file. 

The following logs can be downloaded depending on the SMU version used:

SMU version Downloadable logs

V.3.5 Shadow logs (plus bat and bird protection if available)

V.4.0
· Operating log

· Shadow Casting Log

· Bat protection

· Bird protection

· Sector shutdown

· Noise protection

· Special shutdown

· Single data recording (log of individually defined measured values)

For logging into SMU Auto Logs a user and a password are necessary. 

On delivery, the user admin is created with the password 1234. 



7Introduction > System overview

Manual for SMU Auto Logs 1.0.2.1, Rev. 1.0, 28 Sep 2023 – Modifications and Errors Excepted

System overview2.1
Our system for shadow impact monitoring and species conservation enables you to comply with a
large number of permit conditions that apply to wind turbine generators (WTG), primarily with refe-
rence to shadow impact and species conservation. The following illustration and the corresponding
brief information will help you gain an initial overview of the system and, in particular, identify the
function of SMU Auto Logs within the system.

 1 Shadow Master Unit (SMU): located in the WTG or in a handover station.
The SMU receives project data via Shadow Manager 4, calculates shadow impact periods,
shuts down the WTGs if needed, records readings and alarms, sends appropriate email notifi-
cations, collects log data.

 2 Places of immission (POIs)
Buildings with walls and areas requiring protection.

 3 Light sensor, installed on the nacelle of a WTG
Primarily measures the illuminance of sunlight.

 4 Shadow Manager 4 (SM4): operating software
The project data (coordinates of the WTGs and POIs, permitted shadow impact periods, shut-
down conditions for species conservation and other shutdown specifications) is defined in
SM4. It also reads out measurement data and logs.

 5 SMU Auto Logs
Used to automatically download logs from the Shadow Master Unit V4 (SMU) of our system
for shadow impact and species conservation and export the most important data to a CSV file.

 6 Ethernet connection with encrypted data transmission
Used to transfer project data from SM4 to the SMU and to retrieve measured values and logs
from the SMU.
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NOTE

In order for SMU Auto Logs to do its most important job, which is to automatically download and ex-
port logs, this software must be open (running) at all times. Keep this in mind when you restart your
computer, or add SMU Auto Logs to the Windows autostart feature. As soon as the downloading of
the logs is finished, the connection to the SMU is disconnected (for as long as specified in the sche-
dule) so that evaluating and exporting will  not block the SMU.

SMU Auto Logs is used to automatically download logs from the Shadow Master Unit V4 (SMU) of
our system for shadow impact monitoring and species conservation and export the most important
data to a CSV file. 

The following logs can be downloaded depending on the SMU version used:

SMU version Downloadable logs

V.3.5 Shadow logs (plus bat and bird protection if available)

V.4.0
· Operating log

· Shadow Casting Log

· Bat protection

· Bird protection

· Sector shutdown

· Noise protection

· Special shutdown

· Single data recording (log of individually defined measured values)
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The main window2.2
SMU Auto Logs consists of a main window (see below) within which other windows can be opened.

A

 

B

C

D

Fig.: SMU Auto Logs main window

Element Description

A: Menu bar Access to all menus, menu items, functions and sub-windows.

B: Toolbar Quick access to frequently used functions and subwindows.

C: Views Open subwindows are displayed in this area.

D: Status bar The status bar is always visible. It shows which user is logged in and how
many minutes remain until they are automatically logged out.
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Requirements and installation2.3
You can download the latest version of SMU Auto Logs from our website (www.northtec.de). You
have the choice between an unzipped (.exe) and a zipped (.zip) file.

The program will run as a desktop version.

To use SMU Auto Logs , the following technical requirements must be met:

Prerequisite Description

SMU Shadow Master Unit 3.5 or 4.0 or higher

PC
· at least 2 GB RAM 

· at least 100 MB free hard disk space
(depending on the size of the downloaded logs)

· network port/Internet connection

Operating system SMU Auto Logs runs on computers with the Windows 7 or later operating
system from Microsoft 

Permission No administrator rights required

License To use SMU Auto Logs to its full extent, purchase a license file from us.

To install SMU Auto Logs , double-click on the downloaded .exe file and then follow the on-screen
instructions. Once the installation is complete, the program will open with the login window.

Enter the credentials of the default user created automatically:

User: admin

Password: 1234

Now you can use SMU Auto Logs as described in this manual.

NOTE

In order for SMU Auto Logs to do its most important job, which is to automatically download and ex-
port logs, this software must be open (running) at all times. Keep this in mind when you restart your
computer, or add SMU Auto Logs to the Windows autostart feature. 

As soon as the downloading of the logs is finished, the connection to SMU is disconnected (as long
as specified in the schedule): evaluating and exporting does not block the SMU.
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General features of the software2.4
The menu structure, the assignment of the mouse keys and the design of the application are based
on the usual Windows interface and the corresponding operating elements, with which every user
should be familiar. 

If you feel unsure about using Windows, first familiarize yourself with the basic operation of
Windows (mouse operation, menu technique, resizing windows, etc.).

Notes on the SMU Auto Logs software

· If you enter an invalid value (wrong number or wrong input format) in an input field, it will be
highlighted in red.

· By pressing the Enter key or the Tab key you can end the current input and jump to the next input
field.

· Some buttons, such as Apply and Add, will not be activated in some windows until the mandatory
fields of the window have been filled out correctly.
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3 Menus, windows and tabs
The windows are arranged in menus in SMU Auto Logs and can be accessed through them. Some
windows and functions can be opened directly by clicking on the respective button in the toolbar of
the main window. The function of each icon is displayed as a tool tip when you rest the mouse poin-
ter on it, see the following figure. 

Fig.: Icons in the main window of SMU Auto Logs (with tool tip)

The following table provides an overview of the contents of the individual menus. For more informati-
on, click on the respective cross-reference.

Menu/menu item  What you can do there

File

Exit · Exit program

View

Connections
· Define download schedule

· View/edit data for connection to SMU

· Select logs for download

· Set target folder for log export

· Define filters for individual logs

Monitoring
· Monitor connection status and view logged events

Change password
· Change password for unlocking SMU Auto Logs 

User management
· Change, add or delete SMU Auto Logs users, assign/delete

admin rights

License

License management · View/load/close license file

Settings

Program

Language

· Set session timeout, check for updates

· Select program language

15

29

33

34

36

37
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Menu/menu item  What you can do there

Help

NorthTec Homepage

Check for new version

About SMU Auto Logs

· Go to NorthTec Homepage

· Check for new version of SMU Auto Log s

· Information about SMU Auto Logs, NorthTec contact de-
tails, system information and information about the memory
usage information

The following sections describe the menus in detail.

File menu3.1

Icon Menu item Purpose 

Exit Exit SMU Auto Logs
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View menu3.2
The following table provides an overview of the View menu. For more information, click on the re-
spective cross-reference.

Icon Menu item Purpose

Connections  
· Define download schedule

· View/edit data for connection to SMU

· Select logs for download

· Define storage destination for log export

· Define filters for individual logs.

Monitoring Monitor status of connections and logged events, see 3.2.2 .

Change
password

Change password to unlock SMU Auto Logs, see 3.2.3 .

User
management

Change, add or delete users of SMU Auto Logs, assign/delete
admin rights, see 3.2.4 .

The following sections describe the View menu windows in detail.

15

29
29

33

33

34 34
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3.2.1 Connections window

Purpose Left half of window

· Search/add/remove connections

Right half of window

· Define schedule for download

· View/edit data for connection to the SMU

· Select logs for download

· Define target folder for log export

· Define filters for individual logs

Icon

Path View > Connections

Usage type Display + dialog

Requirement Logged in user
 

Fig.: Connections window 
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Notes on the above Connections window 

· The A section lists connections to SMUs that have already been set up. You can search for spe-
cific SMUs (projects) in the search field. If you then click on Clear, all connected SMUs are dis-
played again. The colored background of the individual connections provides information about the
associated license as follows:
       - License is valid
       - License will expire within 14 days (max.)
       - License is no longer valid

· In area B (connection data), the data of the connection currently selected in area A is dis-
played. For more information, see the table below.

· In area C you select the registers for editing the readout modalities. For more information on the
individual tabs, see the information sections on the individual tabs.



17Menus, windows and tabs > View menu

Manual for SMU Auto Logs 1.0.2.1, Rev. 1.0, 28 Sep 2023 – Modifications and Errors Excepted

Information and/or setting options in the Connection data section: 

In the explanation of the parameters, you will find information on default settings, input format, input
range, etc., depending on their relevance(highlighted in green).

Parameter Explanation

SMU type V3.5 and V4.0 are supported. 

For SMU type V3.5 some settings are disabled(user name and
password, see below, as well as the Download and Filter tabs)

Project name Can be entered individually, but must not be entered twice; otherwise
the field is highlighted in red and the Apply button is disabled.

NOTE

"Project one" and "Project One" are considered different project names.

SMU serial number Can be entered individually, but must not be duplicated; otherwise the
field is highlighted in red and the Apply button is disabled.

NOTE

Serial numbers stored in a loaded license file can be selected here or
are automatically completed when the first characters are entered.

User name Must be stored at the SMU to be addressed. This input field is only
available for SMU type V4.0.

Password Must be stored at the SMU to be addressed. This input field is only
available for SMU type V4.0.

IP address IP address of the SMU to be communicated with.

4 numbers, separated by a dot, example: 192.0.2.42

Port Port number of the SMU to communicate with.

Number from 1 to 65535

Used to remove the connection currently selected in the Connection
area at the top of the window.

In order for entries to be applied, you must click Apply before selecting
another connection/window or exiting SMU Auto Logs .

This button for adding a new connection is active only if all the fields ex-
plained above have been filled in correctly.
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3.2.1.1 Schedule tab

Purpose Set/edit schedule for downloading and exporting logs

Path View > Connections > Schedule

Usage type Display + Dialog

Requirement Logged in user

Fig.: Connections window, Schedule tab 

Information and/or setting options in the Schedule tab

In the explanation of the parameters, you will find information on default settings, input format, input
range, etc., depending on their relevance.(highlighted in green).

Parameter Explanation

Start time Here you define at which time a sequence is to be started. 

Input format: 24-hour format

Cycle: Here you specify the cycle in which a sequence is to be repeated.

Input range: every 4 to 23 hours

In order for entries to be applied, you must click Apply before selecting
another tab/connection/window or exiting SMU Auto Logs .

Preview daily sche-
dule

The result of the entries you have made under Start time and Cycle
 isdisplayed here.
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3.2.1.2 Communication tab

Purpose View and edit data for connection to SMU

Path View > Connections > Communication

Usage type Display + Dialog

Prerequisite Logged in user, SMU type V4.0

(Only the parameters Connection timeout, Connection retries and Read
command timeout are available for SMU type V3.5).

Fig.: Connections window, Communication tab 

The available input fields in the Communication tab are explained in the table below.

Information and/or setting options in the Communication tab

The parameters in this input area correspond to the connection established between SMU Auto
Logs and the SMU. 

In the explanation of the parameters, you will find information on default settings, input format, input
range, etc., depending on their relevance (highlighted in green).

Parameters Explanation

Connection timeout This timeout is used to monitor the initial setup of a connection to a
SMU. As soon as a time defined in the Schedule tab (View > Connec-
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Parameters Explanation

tions) has been reached, SMU Auto Logs will attempt to connect to the
addressed SMU via the network, but only for as long as specified un-
der Connection timeout. If a connection cannot be established during
this time and the number of connect retries has been “used up”, the at-
tempt will be aborted.

Factory default: 4000 ms

Changing this value will take the following effects: 

INCREASE VALUE

· SMU Auto Logs will try to connect to the SMU over a longer period
of time.

DECREASE VALUE

· SMU Auto Logs will abort the attempt to establish a connection
sooner.

Connection retries When establishing a connection to the SMU, the connection attempt is
retried for as many times as specified here and until a connection is
actually established. 

Factory default: 1

Changing this value will take the following effects:

INCREASE VALUE

· If a connection attempt fails, SMU Auto Logs automatically carries
out the number of further attempts specified here.

Time between 2
attempts

After an attempt to connect has failed, SMU Auto Logs will wait as
long as specified here before a new attempt is made (provided that
more than 1 attempt has been specified under Connection retries).

Factory default: 4000 ms

Changing this value will take the following effects: 

INCREASE VALUE

· SMU Auto Logs will wait longer before a new attempt is started;
this may reduce the number of unsuccessful attempts, however, it
may take longer to re-establish a connection.

DECREASE VALUE

· After a connection attempt has failed, SMU Auto Logs will start a
new attempt sooner; thus, the number of unsuccessful attempts
may increase, but the connection may be restored faster.

Read command
timeout

This parameter is identical to the Connection timeout parameter in
terms of its functionality, however, it applies to all other commands (all
commands except the one for establishing a connection).

This timeout monitors the time between sending a command to the
SMU and receiving a response. The value should mainly depend on the
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Parameters Explanation

commands with the longest processing times and on the transmission
time of TCP packets from SMU Auto Logs to the SMU and back.

If SMU Auto Logs, after sending a command, does not receive a
response for the period specified here, SMU Auto Logs will assume
that the connection to the SMU has been lost.

Factory default: 16000 ms

Changing this value will take the following effects: 

INCREASE VALUE

· SMU Auto Logs will wait longer, after sending a command, until it
assumes that the connection to the SMU has been lost due to the
absence of a response. 

DECREASE VALUE

· If SMU Auto Logs, after sending a command, does not receive a
response, it will be quicker to assume that the connection to the
SMU has been lost.

Delay between 2
commands

This parameter determines as to how long SMU Auto Logs, after a
command has been responded to, will wait until a new (different)
command is sent. This will prevent the SMU from getting overloaded.

Factory default: 100 ms

Changing this value will take the following effects: 

INCREASE VALUE

· After sending a command, you will have to wait longer before the
next command can be executed. This way, you can avoid overloa-
ding the SMU.

DECREASE VALUE

· After sending a command, you can execute the next command soo-
ner. However, this can lead to the SMU getting overloaded.

Login refresh interval The only way for SMU Auto Logs and the SMU to reliably determine
whether the connection between them still exists is on the basis of "life
signs" from their connection partner. 

However, if nothing has been transmitted over a certain period of time,
SMU Auto Logs will start a mechanism that sends a ping command to
the SMU at regular intervals and receives the corresponding ping
response. 

This parameter is used to control as to when and how often this me-
chanism is activated. As long as no data commands are sent from
SMU Auto Logs to the SMU, the sending of ping commands is repea-
ted regularly at the interval specified here. 

This prevents the SMU from falsely assuming that it is still involved in a
connection that has long been interrupted (e.g. termination due to a
malfunction in the VPN tunnel) and that it is therefore not available for a
new connection (only one connection can exist at a time).
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Parameters Explanation

This parameter must match the Session timeout parameter, which
controls as to how long the SMU will wait for an “empty command”:
The value on the SMU side (Session timeout) must be higher than the
value on the SMU Auto Logs side (Login refresh interval) to ensure
that SMU Auto Logs definitely sends a command before the SMU ass-
umes that the connection has been interrupted. 

Factory default: 3000 ms

Changing this value will take the following effects: 

INCREASE VALUE

· The monitoring mechanism starts later and the ping commands are
sent at longer intervals. If a connection has been lost, the SMU will
take longer to get ready for new connections. 

DECREASE VALUE

· The monitoring mechanism starts earlier and the ping commands
are sent at shorter intervals. 

Command repetitions This parameter determines as to how often the command is repeated. 

Read file operation
timeout

Commands that affect the SMU file system (e.g. delete file, request di-
rectory) will trigger actions on the SMU that take some time to comple-
te, which also means that it may take some time until a response is
sent back to SMU Auto Logs. Therefore, with actions like these, SMU
Auto Logs has to wait a relatively long time for a response.

The Read file operation timeout parameter is used to make sure
SMU Auto Logs waits for a response as long as file operations usually
take to be completed.

The value should be based on the maximum period of time the SMU ta-
kes to complete a file operation. The transmission time of the channel
is so short that it can be neglected.

Factory default: 360000 ms

Changing this value will take the following effects: 

INCREASE VALUE

· SMU Auto Logs, after having sent a file command and if there is no
answer from the SMU, will wait longer before it assumes that its
connection to the SMU has been lost. 

DECREASE VALUE

· If SMU Auto Logs, after sending a file command, does not receive
a response, it will be quicker to assume that the connection to the
SMU has been lost.
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Parameters Explanation

FSP timeout For data transfers (FSP: File Stream Protocol; download of files) there
is a separate timeout as these tasks usually take longer to be comple-
ted than others. 

Here, too, the value should depend on how long the SMU takes to
complete the respective action. Delays due to the connection channel
do not play a major role.

Factory default: 120000 ms

Changing this value will take the following effects: 

INCREASE VALUE

· SMU Auto Logs, after having sent an upload/download command
and if there is no answer from the SMU, will wait longer before it
assumes that its connection to the SMU has been lost. 

DECREASE VALUE

· If SMU Auto Logs, after sending a an upload/download command,
does not receive a response, it will be quicker to assume that its
connection to the SMU has been lost.

For entries to be applied, you must click Apply before selecting ano-
ther tab/connection/window or before you exit SMU Auto Logs.
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3.2.1.3 Downlad tab

Purpose Set/edit log download schedule

Path View > Connections > Download

Usage type Display + dialog

Prerequisite Logged in user, SMU type V4.0

Fig.: Connections window, Download tab 

Information and/or setting options in the Download tab

In the explanation of the parameters, you will find information on default settings, input format, input
range, etc., depending on their relevance.(highlighted in green).

Parameters Explanation

Storage location Here you can specify for the current connection the folder in which the
downloaded log files should be saved. If the selected/entered directory
cannot be created, a warning is logged and the log files are saved in the
default directory:

(..../<Application>/Data/Download/<SMU_SN_Proj>)

Selection behavior
(months)

Here you specify the months whose logs are to be downloaded.

The drop-down list offers 3 options:

· Current month only

· Current and additional <X> months
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Parameters Explanation

· All available months

If you select the second option of the drop-down list, you must specify
the value for X in the next input field.

Number of additional
months

If you selected the second option in the drop-down list above (Current
and additional <X> months), you must set the value for X here.

Value range: 1 to 999

For entries to be applied, you must click Apply before selecting another
tab/connection/window or before you exit SMU Auto Logs.

3.2.1.4 Export tab

Purpose Set storage destination/behavior for exported logs

Path View > Connections > Export

Usage type Display + dialog

Prerequisite Logged in user

Fig.: Connections window, Export tab 
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Information and/or setting options in the Export tab

Parameters Explanation

Storage location Here you specify the path for the storage destination of the export files.
If the specified directory does not exist, it will be created when the files
are exported. 

The following default path will be selected if the directory cannot be
created: 

<path to SMUAutoLogs.exe file/Export/<project name>

Storage behavior The drop-down list offers 2 options:

· Export files to one folder

· Export files to subfolders

If you choose the second option, you will have to create the Export fol-
der yourself, while the subfolders will be created automatically (including
the subfolders intended for each log).

Create export files Since SMU Auto Logs is used in some cases only for downloading (but
not for exporting log files), you can specify here whether the export files
should be created/export should be executed after downloading.

If this option is enabled, export files are always created only for those
logs that have been newly downloaded. 

Note for SMU version 4.0:

If no check mark is set here, then the status Disabled is displayed in the
Evaluate and Export columns in the Monitoring area (View > Monito-
ring).

Note for SMU version 3.5:

If no check mark is set here, then the status Disabled is displayed in the
Export column in the Monitoring area (View > Monitoring).

For entries to be applied, you must click Apply before selecting another
tab/connection/window or before you exit SMU Auto Logs.
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3.2.1.5 Filter tab

Purpose Define event filter for the selected log type

Path View > Connections > Filter

Usage type Display + dialog

Prerequisite Logged in user, SMU type V4.0

The filter settings refer only to the selected SMU. By selecting the event filter (and thus specific
events), you will cause the logged measured values of the "activated" event to be written to the ex-
port file (evaluation).

Fig.: Connections window, Filter tab 

Information and/or setting options in the Filter tab

Parameters Explanation

Event filter Selection of the log type whose event filter is to be changed:

Regarding Single Data Recordings (Measurement data logging), all log-
ged events are exported; there are no preset filters, as these result from



28Menus, windows and tabs > View menu

Manual for SMU Auto Logs 1.0.2.1, Rev. 1.0, 28 Sep 2023 – Modifications and Errors Excepted

Parameters Explanation

the settings in the SM4 project. This option is only included for the sake
of completeness.

By selecting the event filter (and thus specific events), you will cause the
logged measured values of the „activated” event to be written to the ex-
port file (evaluation).

If you have changed one of the predefined event filters, you can click this
button to reset the currently selected event filter to its predefined state.

(bottom left of the
tab)

If you click this button, the Copy
Event Filter subwindow opens:

Here you can select filters of the
currently active connection and ea-
sily copy them to other connecti-
ons.

To do this, place a check mark for
the filters to be copied in the upper
half and a check mark for the
connections into which you want to
copy the filters in the lower half.

Then click on Copy.

For entries to be applied, you must click Apply before selecting another
tab/connection/window or before you exit SMU Auto Logs.
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3.2.2 Monitoring window

Purpose Monitor status of connections and display logged events

Icon

Path View > Monitoring

Usage type Display + Dialog

 

Fig.: Monitoring window (section thereof)

Notes on the above window

· The upper table of the window displays an overview of the added connections with their current
status. Double-clicking on a connection displays the events logged for that connection in the
lower table.

· Depending on the selection, the lower table displays the following:

- the logged events of one active connection - OR-

- all errors and warnings of all connections - OR -

- Messages for all connections.

See also: Upper table , Lower table  in the Monitoring window30 31
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3.2.2.1 Upper table in the Monitoring window

To access the Monitoring window, select View > Monitoring or click .

The upper table displays an overview of the added connections with their current status. 

Double-click on a connection to display the logged events of that connection in the lower table.

The following figure shows an example of a table with three connections added.

Fig.: Upper table in the Monitoring  window (section)

The following overview explains the individual columns of the table:

Column Explanation

Info SMU type, project name and SMU serial number as defined in the Connec-
tions window.

Procedure

(includes all work
steps)

Procedure refers to the set of steps (License, Connect, List, etc.) listed
in the columns to the right of the Procedure column and explained later in
this table.

A procedure is triggered whenever a point of time specified in the schedule
(View > Connections> Schedule) has been reached.

The following may be displayed under Current Status:

· Pending: Waiting for the next start of a procedure 

· Progress: Procedure or work step is currently active

· Error: An error has occurred in one of the steps of the procedure (to
determine the exact step, check for another column in which Error is al-
so displayed).

· Finished: This status is only displayed for a single work step that has
been completed.

The Start and End columns indicate as to when a procedure was started
(depending on the schedule) and when the corresponding data was saved
to CSV files or respectively when the procedure was terminated by an er-
ror.

Once a procedure has been completed, the status messages of the work
steps are retained so that you can see whether the last procedure was car-
ried out successfully or, if not, the work step in which an error occurred.

The individual steps are explained from here on ...
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Column Explanation

License This step checks whether the license for the connection is valid or whether
a license exists.

Connect SMU Auto Logs attempts to connect to the SMU.

List* Downloadable log files are identified and prepared for selection.

Select* Log files to be downloaded are selected.

Download Log files are being downloaded. Once all files have been downloaded, SMU
Auto Logs logs out of the SMU.

Evaluate The downloaded log files are evaluated and exported month by month.

Note for SMU version 4.0:

If the Create export files option has been disabled in the Export tab (View
> Export), then the status Disabled is displayed here.

Export The most important data of an evaluated monthly log file are stored in a
CSV file.

Note for both SMU versions (3.5 and 4.0):

If the Create export files option has been disabled in the Export tab (View
> Export), then the status Disabled is displayed here.

*With the SMU type V3.5, the progress is always set immediately to 100 %.

3.2.2.2 Lower table in the Monitoring window

To access the Monitoring window, select View > Monitoring or click .

· The lower table displays the following, depending on the selection made

- the logged events of one active connection

OR 

- all errors and warnings of all connections

OR 

- messages for all connections.

Double-clicking on a connection displays the logged events in the lower table.
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The following figure shows an example of a table with four connections added.

Fig.: Lower table in the Monitoring window

The columns of the table are named in a self-explanatory way. 

The following overview explains the available buttons.

Button Explanation

This button displays the logged events of a connection. In order to display the
logged events, a connection must be selected from the upper table.

Double-clicking on a connection in the upper half of the window does the sa-
me.

Displays all logged errors and warnings of all connections. No connection
needs to be selected for this button.

Notifications lists all errors and warnings that have been logged since the last
time the Reset button was pressed.

Clicking on  in the menu bar has the same effect.

This button "resets" the accumulated messages .

After clicking this button, the red circle with the exclamation mark displayed at

the Notifications icon ( ) in the toolbar will disappear.

If you now click on Notifications again, nothing will be displayed unless new
errors or warnings have been logged since you last clicked Reset.
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3.2.3 Change Password window

Purpose Change password of the currently logged in user

Path View > Change password 

Usage type Dialog 

Requirement Logged in user

In this window the currently logged in user can change his password. 

Fig.: Change password window

To change the password, first enter the old password, then enter the new one twice, and then click
Change.
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3.2.4 User Management window

Purpose Change, add or delete user SMU Auto Logs users 

Assign/delete user rights 

Path View > User Management 

Usage type Display + Dialog 

Requirement Admin right

In this window users with admin rights can add, modify or delete other users and also assign/delete
admin rights.

Fig.: User Management window

Existing users are displayed in the upper half of the window; edit, add or delete users in the lower
half.

Information and/or setting options User Management window

Input field/
button

Explanation

User Input any character
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Input field/
button

Explanation

Password Input any character, but note the following information in the window:

Description This field has no defined function, the text can be freely chosen.

Max. 80 characters.

Admin If you check this box when creating a user, the future user will also be allowed
to open the User Management window (= this window ) and License Mana-
gement window.

self-explanatory

Removes the user selected in the list above.

Note the following hint in the window:

see above
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License menu3.3
In the License menu there is only the License Management menu item.

See also: License Management window

3.3.1 License Management window

Purpose Display, load and close license file

Path View > User Management 

Usage type Display + dialog 

Requirement Admin right

In this window you will find an overview of the licenses contained in the currently loaded license file.
You can also close an "old" license file here and load a newly acquired one.

Fig: License Management window

Notes on the above example

· Licenses 1 + 9 will expire soon and cannot be renewed, but must be replaced with new licenses.

· Licenses 2, 3, 7, 8, and 10 are unlimited licenses.

· Licenses 4, 5, and 6 are displayed in red because they have already expired.

· Use the Open License File button to select a license file that you want to load.

· Use the Close License File button to remove the currently loaded license file.

36
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Settings menu3.4
The following table provides an overview of the Settings menu. For more information, click on the
cross-reference.

Menu item Purpose

Program  
· Set session timeout

· Check for updates

Language
· Select program language

3.4.1 Program window

Purpose Set session timeout, check for updates

Path Settings > Program 

Usage type Display + dialog 

Prerequisite Logged in user

Fig.: Program window

37
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Information and/or setting options in the Program window

In the explanation of the parameters, you will find information on default settings, input format, input
range, etc., depending on their relevance (highlighted in green).

Input field/ button Explanation

Duration After the time specified here has elapsed, a logged-in user is
logged out.

Input: 5 to 60 minutes

Active If checked, SMU Auto Logs automatically checks every <x>
hours in the background whether a new version is available.

All At the interval <x> specified here, the system automatically
checks whether there are any updates for SMU Auto Logs.

Input: 1 to 9000 hours 

3.4.2 Language menu item

Purpose Switch between English and German user interfaces

Path Settings > Language 

Usage type Dialog 

Requirement none
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Help menu3.5

Icon Window Description

NorthTec Homepage Call up the NorthTec homepage.

Check for new
version

When you select this menu item, the system checks online
whether there are any updates for SMU Auto Logs .

About SMU Auto
Logs

Displays information about the software version, the Nor-
thTec company, the operating system used, and the memory
usage
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